using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2,}(:|,)){3}\d{2,} --> (\d{2,}(:|,)){3}\d{2,}";
string input = @"00:00:09,220 --> 00:00:10,950";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}