re = /(\d{2,}(:|,)){3}\d{2,} --> (\d{2,}(:|,)){3}\d{2,}/
str = '00:00:09,220 --> 00:00:10,950'
# Print the match result
str.match(re) do |match|
puts match.to_s
end