import re
regex = re.compile(r"(\d{2,}(:|,)){3}\d{2,} --> (\d{2,}(:|,)){3}\d{2,}")
test_str = "00:00:09,220 --> 00:00:10,950"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")