$re = '/(\d{2,}(:|,)){3}\d{2,} --> (\d{2,}(:|,)){3}\d{2,}/';
$str = '00:00:09,220 --> 00:00:10,950';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);