package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2,}(:|,)){3}\d{2,} --> (\d{2,}(:|,)){3}\d{2,}`)
var str = `00:00:09,220 --> 00:00:10,950`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}