package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Function(.*?)End Function`)
var str = `Function this is the function itself with a End End Function`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}