re = /Function(.*?)End Function/
str = 'Function this is the function itself with a End End Function'
# Print the match result
str.match(re) do |match|
puts match.to_s
end