using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?<\/a>|http:\/\/\S+";
string input = @"adasdas http://www.stackoverflow.com asdasas
adasdasahttp://www.stackoverflow.com/something asdas
adasdas<a href=""somelink""> http://www.stackoverflow.com </a>asdasas
adasdasa<a href=""somelink"">http://www.stackoverflow.com/something</a> asdas";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}