package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*?<\/a>|http:\/\/\S+`)
var str = `adasdas http://www.stackoverflow.com asdasas
adasdasahttp://www.stackoverflow.com/something asdas
adasdas<a href="somelink"> http://www.stackoverflow.com </a>asdasas
adasdasa<a href="somelink">http://www.stackoverflow.com/something</a> asdas`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}