re = /<a.*?<\/a>|http:\/\/\S+/
str = 'adasdas http://www.stackoverflow.com asdasas
adasdasahttp://www.stackoverflow.com/something asdas
adasdas<a href="somelink"> http://www.stackoverflow.com </a>asdasas
adasdasa<a href="somelink">http://www.stackoverflow.com/something</a> asdas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end