// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<a.*?<\/a>|http:\/\/\S+").unwrap();
let string = "adasdas http://www.stackoverflow.com asdasas
adasdasahttp://www.stackoverflow.com/something asdas
adasdas<a href=\"somelink\"> http://www.stackoverflow.com </a>asdasas
adasdasa<a href=\"somelink\">http://www.stackoverflow.com/something</a> asdas";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}