import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?<\\/a>|http:\\/\\/\\S+";
final String string = "adasdas http://www.stackoverflow.com asdasas\n"
+ "adasdasahttp://www.stackoverflow.com/something asdas\n"
+ "adasdas<a href=\"somelink\"> http://www.stackoverflow.com </a>asdasas\n"
+ "adasdasa<a href=\"somelink\">http://www.stackoverflow.com/something</a> asdas";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}