#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*(\d{4}))(?=.*\b(Canada|Malaysia|France|South Africa)\b)"
Local $sString = "This is just the title and has no year or country:" & @CRLF & _
"Preamble with only year 1999 and no country:" & @CRLF & _
"I was born in 1990 in Canada, I was born to love, and be loved." & @CRLF & _
"She was born in 2000 in Malaysia and she likes fishing." & @CRLF & _
"My mother was born in South Africa and she love all her sons and daughters, she was born in 1960." & @CRLF & _
"My Dad was born in a small village in France in 1955. He loves my Mom." & @CRLF & _
"and finally thanks from USA, without a year." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")