const regex = /^(?=.*(\d{4}))(?=.*\b(Canada|Malaysia|France|South Africa)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(\\d{4}))(?=.*\\b(Canada|Malaysia|France|South Africa)\\b)', 'gm')
const str = `This is just the title and has no year or country:
Preamble with only year 1999 and no country:
I was born in 1990 in Canada, I was born to love, and be loved.
She was born in 2000 in Malaysia and she likes fishing.
My mother was born in South Africa and she love all her sons and daughters, she was born in 1960.
My Dad was born in a small village in France in 1955. He loves my Mom.
and finally thanks from USA, without a year.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}