import Foundation
let pattern = #"^(?=.*(\d{4}))(?=.*\b(Canada|Malaysia|France|South Africa)\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is just the title and has no year or country:
Preamble with only year 1999 and no country:
I was born in 1990 in Canada, I was born to love, and be loved.
She was born in 2000 in Malaysia and she likes fishing.
My mother was born in South Africa and she love all her sons and daughters, she was born in 1960.
My Dad was born in a small village in France in 1955. He loves my Mom.
and finally thanks from USA, without a year.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)