use strict;
my $str = 'This is just the title and has no year or country:
Preamble with only year 1999 and no country:
I was born in 1990 in Canada, I was born to love, and be loved.
She was born in 2000 in Malaysia and she likes fishing.
My mother was born in South Africa and she love all her sons and daughters, she was born in 1960.
My Dad was born in a small village in France in 1955. He loves my Mom.
and finally thanks from USA, without a year.
';
my $regex = qr/^(?=.*(\d{4}))(?=.*\b(Canada|Malaysia|France|South Africa)\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}