import re
regex = re.compile(r"^(?=.*(\d{4}))(?=.*\b(Canada|Malaysia|France|South Africa)\b)", flags=re.MULTILINE)
test_str = ("This is just the title and has no year or country:\n"
"Preamble with only year 1999 and no country:\n"
"I was born in 1990 in Canada, I was born to love, and be loved.\n"
"She was born in 2000 in Malaysia and she likes fishing.\n"
"My mother was born in South Africa and she love all her sons and daughters, she was born in 1960.\n"
"My Dad was born in a small village in France in 1955. He loves my Mom.\n"
"and finally thanks from USA, without a year.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")