#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "x+[^xy]*z[^xy]*y+"
Local $sString = "xx hello " & @CRLF & _
"zz " & @CRLF & _
"yy" & @CRLF & _
"" & @CRLF & _
"xx cruel yy" & @CRLF & _
"" & @CRLF & _
"xx world zz yy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")