package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`x+[^xy]*z[^xy]*y+`)
var str = `xx hello
zz
yy
xx cruel yy
xx world zz yy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}