$re = '/x+[^xy]*z[^xy]*y+/';
$str = 'xx hello
zz
yy
xx cruel yy
xx world zz yy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);