// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"x+[^xy]*z[^xy]*y+").unwrap();
let string = "xx hello
zz
yy
xx cruel yy
xx world zz yy";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}