using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"x+[^xy]*z[^xy]*y+";
string input = @"xx hello
zz
yy
xx cruel yy
xx world zz yy";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}