#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}$"
Local $sString = "abcd-1234yz" & @CRLF & _
"abcd1234yz" & @CRLF & _
"abcd1234yz" & @CRLF & _
"abcd1234yz" & @CRLF & _
"1ca4tc7f-22ab-4d55-91d2-58a821ceb4c4" & @CRLF & _
"1ca4tc7f-227b-4d55-91d2-58a821ceb4c42" & @CRLF & _
"1ca4tc7f2-227b-4d55-91d2-58a821ceb4c49"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")