use strict;
my $str = 'abcd-1234yz
abcd1234yz
abcd1234yz
abcd1234yz
1ca4tc7f-22ab-4d55-91d2-58a821ceb4c4
1ca4tc7f-227b-4d55-91d2-58a821ceb4c42
1ca4tc7f2-227b-4d55-91d2-58a821ceb4c49';
my $regex = qr/^[a-z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}