$re = '/^[a-z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}$/m';
$str = 'abcd-1234yz
abcd1234yz
abcd1234yz
abcd1234yz
1ca4tc7f-22ab-4d55-91d2-58a821ceb4c4
1ca4tc7f-227b-4d55-91d2-58a821ceb4c42
1ca4tc7f2-227b-4d55-91d2-58a821ceb4c49';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);