using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}$";
string input = @"abcd-1234yz
abcd1234yz
abcd1234yz
abcd1234yz
1ca4tc7f-22ab-4d55-91d2-58a821ceb4c4
1ca4tc7f-227b-4d55-91d2-58a821ceb4c42
1ca4tc7f2-227b-4d55-91d2-58a821ceb4c49";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}