import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}$";
final String string = "abcd-1234yz\n"
+ "abcd1234yz\n"
+ "abcd1234yz\n"
+ "abcd1234yz\n"
+ "1ca4tc7f-22ab-4d55-91d2-58a821ceb4c4\n"
+ "1ca4tc7f-227b-4d55-91d2-58a821ceb4c42\n"
+ "1ca4tc7f2-227b-4d55-91d2-58a821ceb4c49";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}