#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!\([^\s*\,])\s*,\s*(?![^"']*('|")\))"
Local $sString = "sdfsf,sdfsdf,asdsd(),sdfsdf('3',33, "22"),dfgdfgdg,sdfsdf("hg,gh"),jhkjh(',k,k'),jhkjh('sd,'),jhkjh('sd'),asdad(','),asdasd(",sss"),kjkj,hghjg(",jhgjh,h"),sdfsf:jhjh(""),sdfsf:jhjh("asd()asd,()"),hghjg(",("),hghjg(',(WE2'),ASDASD,sdfsf:jhjh("asd(), asd)"),"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")