re = /(?!\([^\s*\,])\s*,\s*(?![^"']*('|")\))/
str = 'sdfsf,sdfsdf,asdsd(),sdfsdf(\'3\',33, "22"),dfgdfgdg,sdfsdf("hg,gh"),jhkjh(\',k,k\'),jhkjh(\'sd,\'),jhkjh(\'sd\'),asdad(\',\'),asdasd(",sss"),kjkj,hghjg(",jhgjh,h"),sdfsf:jhjh(""),sdfsf:jhjh("asd()asd,()"),hghjg(",("),hghjg(\',(WE2\'),ASDASD,sdfsf:jhjh("asd(), asd)"),'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end