import Foundation
let pattern = #"(?!\([^\s*\,])\s*,\s*(?![^"']*('|")\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"sdfsf,sdfsdf,asdsd(),sdfsdf('3',33, "22"),dfgdfgdg,sdfsdf("hg,gh"),jhkjh(',k,k'),jhkjh('sd,'),jhkjh('sd'),asdad(','),asdasd(",sss"),kjkj,hghjg(",jhgjh,h"),sdfsf:jhjh(""),sdfsf:jhjh("asd()asd,()"),hghjg(",("),hghjg(',(WE2'),ASDASD,sdfsf:jhjh("asd(), asd)"),"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)