const regex = /(?!\([^\s*\,])\s*,\s*(?![^"']*('|")\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\([^\\s*\\,])\\s*,\\s*(?![^"\']*(\'|")\\))', 'g')
const str = `sdfsf,sdfsdf,asdsd(),sdfsdf('3',33, "22"),dfgdfgdg,sdfsdf("hg,gh"),jhkjh(',k,k'),jhkjh('sd,'),jhkjh('sd'),asdad(','),asdasd(",sss"),kjkj,hghjg(",jhgjh,h"),sdfsf:jhjh(""),sdfsf:jhjh("asd()asd,()"),hghjg(",("),hghjg(',(WE2'),ASDASD,sdfsf:jhjh("asd(), asd)"),`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}