import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d]{1});([\\d]{1});([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\dZ-a]*);([\\d\\sA-Z]*);([\\w\\s\\.\\d\\-\\/\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*)[MGB]{2};([\\w\\s\\.\\d\\-\\/\\(\\)]*);([0-9])";
final String string = "0;1;;Alpha Media Lab;Alpha Media Lab;Administratie;M2M;Haringvliet;68;3011 TG;Rotterdam;8 dagen;700;45;11;30;5MB;;0\n"
+ "0;0;Clear Channel ;Clear Channel Hillenaar ;;Administratie;;;;;;;2250;45;15;30;1GB;;1";
final String subst = "UPDATE [dbo].[Customer]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}