const regex = /([\d]{1});([\d]{1});([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\dZ-a]*);([\d\sA-Z]*);([\w\s\.\d\-\/\(\)]*);([\w\s\.\d\-\(\)]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*)[MGB]{2};([\w\s\.\d\-\/\(\)]*);([0-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d]{1});([\\d]{1});([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([\\dZ-a]*);([\\d\\sA-Z]*);([\\w\\s\\.\\d\\-\\\/\\(\\)]*);([\\w\\s\\.\\d\\-\\(\\)]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*)[MGB]{2};([\\w\\s\\.\\d\\-\\\/\\(\\)]*);([0-9])', 'g')
const str = `0;1;;Alpha Media Lab;Alpha Media Lab;Administratie;M2M;Haringvliet;68;3011 TG;Rotterdam;8 dagen;700;45;11;30;5MB;;0
0;0;Clear Channel ;Clear Channel Hillenaar ;;Administratie;;;;;;;2250;45;15;30;1GB;;1`;
const subst = `UPDATE [dbo].[Customer]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);