using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\d{3}\)(-| )\d{3}(-| )*\d{4}";
string input = @"phone:(646)-270-9821
phone:(123)-323-4363
phone:(13)-323-4363
phone:(132)-323-436
phone:(abc)-323-4363
phone:(646)-270_9821
phone:(646)-270 9821
phone:(646)-2709821";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}