package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\(\d{3}\)(-| )\d{3}(-| )*\d{4}`)
var str = `phone:(646)-270-9821
phone:(123)-323-4363
phone:(13)-323-4363
phone:(132)-323-436
phone:(abc)-323-4363
phone:(646)-270_9821
phone:(646)-270 9821
phone:(646)-2709821`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}