// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\(\d{3}\)(-| )\d{3}(-| )*\d{4}").unwrap();
let string = "phone:(646)-270-9821
phone:(123)-323-4363
phone:(13)-323-4363
phone:(132)-323-436
phone:(abc)-323-4363
phone:(646)-270_9821
phone:(646)-270 9821
phone:(646)-2709821";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}