use strict;
my $str = 'phone:(646)-270-9821
phone:(123)-323-4363
phone:(13)-323-4363
phone:(132)-323-436
phone:(abc)-323-4363
phone:(646)-270_9821
phone:(646)-270 9821
phone:(646)-2709821';
my $regex = qr/\(\d{3}\)(-| )\d{3}(-| )*\d{4}/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}