$re = '/\(\d{3}\)(-| )\d{3}(-| )*\d{4}/i';
$str = 'phone:(646)-270-9821
phone:(123)-323-4363
phone:(13)-323-4363
phone:(132)-323-436
phone:(abc)-323-4363
phone:(646)-270_9821
phone:(646)-270 9821
phone:(646)-2709821';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);