#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)"
Local $sString = "# Test" & @CRLF & _
"" & @CRLF & _
"| Demo Name / Link | Tweet size description | Key Elements | PRPs / Authors | Video/Recording | Last Updated |" & @CRLF & _
"|-----------------------------------------------------------------------------------------------------------------------|-------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------|------------------------|---------------------------------------------------------------------------------------------------------------|------------------|" & @CRLF & _
"| [Azure Pipelines, Functions and Luis](end-to-end-demos/azure-devops-pipelines) | Great demo to show the power of GitHub with Serverless Functions and the fancy LUIS API. | Azure Pipelines, Azure Functions, Microsoft LUIS and GitHub Flow | @pierluigi | [Video Walkthrough](https://www.youtube.com/watch?v=OrAuvkcuB7Y) | 23/October/2018 |" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")