import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\|([^|]+)\\|([^|]+)\\|([^|]+)\\|([^|]+)\\|([^|]+)\\|([^|]+)";
final String string = "# Test\n\n"
+ "| Demo Name / Link | Tweet size description | Key Elements | PRPs / Authors | Video/Recording | Last Updated |\n"
+ "|-----------------------------------------------------------------------------------------------------------------------|-------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------|------------------------|---------------------------------------------------------------------------------------------------------------|------------------|\n"
+ "| [Azure Pipelines, Functions and Luis](end-to-end-demos/azure-devops-pipelines) | Great demo to show the power of GitHub with Serverless Functions and the fancy LUIS API. | Azure Pipelines, Azure Functions, Microsoft LUIS and GitHub Flow | @pierluigi | [Video Walkthrough](https://www.youtube.com/watch?v=OrAuvkcuB7Y) | 23/October/2018 |\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}