import Foundation
let pattern = #"^\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
# Test
| Demo Name / Link | Tweet size description | Key Elements | PRPs / Authors | Video/Recording | Last Updated |
|-----------------------------------------------------------------------------------------------------------------------|-------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------|------------------------|---------------------------------------------------------------------------------------------------------------|------------------|
| [Azure Pipelines, Functions and Luis](end-to-end-demos/azure-devops-pipelines) | Great demo to show the power of GitHub with Serverless Functions and the fancy LUIS API. | Azure Pipelines, Azure Functions, Microsoft LUIS and GitHub Flow | @pierluigi | [Video Walkthrough](https://www.youtube.com/watch?v=OrAuvkcuB7Y) | 23/October/2018 |
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)