using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)";
string input = @"# Test
| Demo Name / Link | Tweet size description | Key Elements | PRPs / Authors | Video/Recording | Last Updated |
|-----------------------------------------------------------------------------------------------------------------------|-------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------|------------------------|---------------------------------------------------------------------------------------------------------------|------------------|
| [Azure Pipelines, Functions and Luis](end-to-end-demos/azure-devops-pipelines) | Great demo to show the power of GitHub with Serverless Functions and the fancy LUIS API. | Azure Pipelines, Azure Functions, Microsoft LUIS and GitHub Flow | @pierluigi | [Video Walkthrough](https://www.youtube.com/watch?v=OrAuvkcuB7Y) | 23/October/2018 |
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}