#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[_](?![_\s])(.*?[^_\s])[_]\b"
Local $sString = "*em" & @CRLF & _
"_em" & @CRLF & _
"*em*" & @CRLF & _
"*em_" & @CRLF & _
"_em*" & @CRLF & _
"_em_" & @CRLF & _
"*em**" & @CRLF & _
"_em__" & @CRLF & _
"**em*" & @CRLF & _
"__em_" & @CRLF & _
"**em**" & @CRLF & _
"__em__" & @CRLF & _
"ins*ide*" & @CRLF & _
"*te*xt" & @CRLF & _
"in*si*de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")