import re
regex = re.compile(r"\b[_](?![_\s])(.*?[^_\s])[_]\b", flags=re.MULTILINE)
test_str = ("*em\n"
"_em\n"
"*em*\n"
"*em_\n"
"_em*\n"
"_em_\n"
"*em**\n"
"_em__\n"
"**em*\n"
"__em_\n"
"**em**\n"
"__em__\n"
"ins*ide*\n"
"*te*xt\n"
"in*si*de")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")