re = /\b[_](?![_\s])(.*?[^_\s])[_]\b/m
str = '*em
_em
*em*
*em_
_em*
_em_
*em**
_em__
**em*
__em_
**em**
__em__
ins*ide*
*te*xt
in*si*de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end