import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[_](?![_\\s])(.*?[^_\\s])[_]\\b";
final String string = "*em\n"
+ "_em\n"
+ "*em*\n"
+ "*em_\n"
+ "_em*\n"
+ "_em_\n"
+ "*em**\n"
+ "_em__\n"
+ "**em*\n"
+ "__em_\n"
+ "**em**\n"
+ "__em__\n"
+ "ins*ide*\n"
+ "*te*xt\n"
+ "in*si*de";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}