$re = '/\b[_](?![_\s])(.*?[^_\s])[_]\b/m';
$str = '*em
_em
*em*
*em_
_em*
_em_
*em**
_em__
**em*
__em_
**em**
__em__
ins*ide*
*te*xt
in*si*de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);