#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:\s+(?:and|or|if)\s+)|"[^"]+")(*SKIP)(*FAIL)|\s+"
Local $sString = "" & @CRLF & _
"lorem and ipsum or other ipsum" & @CRLF & _
"if not sid amet then lorem ipsum again" & @CRLF & _
""let me completely alone"" & @CRLF & _
"" & @CRLF & _
"some fantastic whitespaces all over here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")