import re
regex = re.compile(r"(?:(?:\s+(?:and|or|if)\s+)|\"[^\"]+\")(*SKIP)(*FAIL)|\s+", flags=re.MULTILINE)
test_str = ("\n"
"lorem and ipsum or other ipsum\n"
"if not sid amet then lorem ipsum again\n"
"\"let me completely alone\"\n\n"
"some fantastic whitespaces all over here")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")