using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\s+(?:and|or|if)\s+)|""[^""]+"")(*SKIP)(*FAIL)|\s+";
string input = @"
lorem and ipsum or other ipsum
if not sid amet then lorem ipsum again
""let me completely alone""
some fantastic whitespaces all over here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}